All times are UTC + 8 hours




Post new topic Reply to topic  [ 427 posts ]  Go to page Previous  1 ... 25, 26, 27, 28, 29
Author Message
PostPosted: Dec 18th, '17, 08:38 
Offline
Newbie
Newbie
User avatar

Joined: Dec 17th, '17, 22:27
Posts: 25
Location: Right Here
Gender: Male
Are you human?: Only after coffee
Location: Ravenna, Ohio U.S.A.
I know this is an old thread, but I was verifying/ compiling the arduino program and keep getting the following error message:

Arduino: 1.6.0 (Windows 8), Board: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

chiumanfu_aquaponic_controller.ino:41:55: fatal error: LiquidCrystalFast.h: No such file or directory
compilation terminated.
Error compiling.


Any Ideas? Any and all input will be helpful.

Thank you in advance,

Chris

_________________
Give a man a fish , he eats for a day. Teach a man to fish, he sits in a boat and drinks beer all day. :drunken:


Top
 Profile  
Reply with quote  
    Advertisement
 
PostPosted: Dec 18th, '17, 23:38 
Offline
Legend Member
Legend Member

Joined: Jan 6th, '15, 06:49
Posts: 521
Gender: Male
Are you human?: when in a good mood
Location: Santee, CA USA
I wish I could help but I just don't know Arduinos that well. Perhaps you need to load a library or get an updated copy for the LCD you are using?

_________________
800 gal sys 2016
IBC system 1/2015
simple flood & drain
5 growbeds

9 kW Solar Electric 2011

"Aquaponics...solar-powered nanotechnology that produces fresh vegetables and meat, while purifying water..." - Rick Op, Houston Texas.


Top
 Profile  
Reply with quote  
PostPosted: Dec 19th, '17, 11:10 
Offline
Newbie
Newbie

Joined: Jul 14th, '17, 00:07
Posts: 19
Gender: Male
Are you human?: YES
Location: USA, Texas
usmick78 wrote:
I know this is an old thread, but I was verifying/ compiling the arduino program and keep getting the following error message:

Arduino: 1.6.0 (Windows 8), Board: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

chiumanfu_aquaponic_controller.ino:41:55: fatal error: LiquidCrystalFast.h: No such file or directory
compilation terminated.
Error compiling.


Any Ideas? Any and all input will be helpful.

Thank you in advance,

Chris


The error message is telling you that a file named 'LiquidCrystalFast.h' is missing from your Arduino compiler's library. I think if you look at the very beginning of the code you should see a line something like this: #include LiquidCrystalFast.h; . The code is expecting to reference information in that file as it executes. You can use google to try and find the file and then add it to your library.


Top
 Profile  
Reply with quote  
PostPosted: Dec 19th, '17, 11:39 
Offline
Newbie
Newbie

Joined: Jul 14th, '17, 00:07
Posts: 19
Gender: Male
Are you human?: YES
Location: USA, Texas
You can find the library here:

https://github.com/Swap-File/tron-suit/tree/master/Helmet/Software/Libraries/LiquidCrystalFast


Top
 Profile  
Reply with quote  
PostPosted: Dec 20th, '17, 04:18 
Offline
Newbie
Newbie
User avatar

Joined: Dec 17th, '17, 22:27
Posts: 25
Location: Right Here
Gender: Male
Are you human?: Only after coffee
Location: Ravenna, Ohio U.S.A.
By the way, anyone trying is to find the original files, they can be found here:

https://github.com/Chiumanfu/Chiumanfu- ... Controller

_________________
Give a man a fish , he eats for a day. Teach a man to fish, he sits in a boat and drinks beer all day. :drunken:


Top
 Profile  
Reply with quote  
PostPosted: Jun 4th, '19, 06:35 
Offline
Newbie
Newbie
User avatar

Joined: Dec 17th, '17, 22:27
Posts: 25
Location: Right Here
Gender: Male
Are you human?: Only after coffee
Location: Ravenna, Ohio U.S.A.
Will a probe compatible with an Arduino UNO work with the Mega 2560?

_________________
Give a man a fish , he eats for a day. Teach a man to fish, he sits in a boat and drinks beer all day. :drunken:


Top
 Profile  
Reply with quote  
PostPosted: Jun 4th, '19, 07:27 
Offline

Joined: Nov 25th, '15, 03:36
Posts: 6
Gender: Male
Are you human?: always
Location: EDOMEX, Mexico
usmick78 wrote:
Will a probe compatible with an Arduino UNO work with the Mega 2560?



Good day usmick78

Working code for an 'Uno' can be ported to the 'Mega 2560', ie; pin layout is different between the two boards.

Good to see interest in this thread after so many years have past. I am about to start (again) with this project as well. Will probably use the latest generation of Atlas Scientific probes ( although the original project code does not support them).

take care, peace
lost_bro


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 427 posts ]  Go to page Previous  1 ... 25, 26, 27, 28, 29

All times are UTC + 8 hours


Who is online

Users browsing this forum: Google [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB® Forum Software © phpBB Group
Portal by phpBB3 Portal © phpBB Türkiye
[ Time : 0.068s | 18 Queries | GZIP : Off ]